코딩테스트/그래프 탐색

[Java] 백준 1261번 : 알고스팟

sujin7837 2022. 3. 31. 13:47
반응형

문제

알고스팟 운영진이 모두 미로에 갇혔다. 미로는 N*M 크기이며, 총 1*1크기의 방으로 이루어져 있다. 미로는 빈 방 또는 벽으로 이루어져 있고, 빈 방은 자유롭게 다닐 수 있지만, 벽은 부수지 않으면 이동할 수 없다.

알고스팟 운영진은 여러명이지만, 항상 모두 같은 방에 있어야 한다. 즉, 여러 명이 다른 방에 있을 수는 없다. 어떤 방에서 이동할 수 있는 방은 상하좌우로 인접한 빈 방이다. 즉, 현재 운영진이 (x, y)에 있을 때, 이동할 수 있는 방은 (x+1, y), (x, y+1), (x-1, y), (x, y-1) 이다. 단, 미로의 밖으로 이동 할 수는 없다.

벽은 평소에는 이동할 수 없지만, 알고스팟의 무기 AOJ를 이용해 벽을 부수어 버릴 수 있다. 벽을 부수면, 빈 방과 동일한 방으로 변한다.

만약 이 문제가 알고스팟에 있다면, 운영진들은 궁극의 무기 sudo를 이용해 벽을 한 번에 다 없애버릴 수 있지만, 안타깝게도 이 문제는 Baekjoon Online Judge에 수록되어 있기 때문에, sudo를 사용할 수 없다.

현재 (1, 1)에 있는 알고스팟 운영진이 (N, M)으로 이동하려면 벽을 최소 몇 개 부수어야 하는지 구하는 프로그램을 작성하시오.

입력

첫째 줄에 미로의 크기를 나타내는 가로 크기 M, 세로 크기 N (1 ≤ N, M ≤ 100)이 주어진다. 다음 N개의 줄에는 미로의 상태를 나타내는 숫자 0과 1이 주어진다. 0은 빈 방을 의미하고, 1은 벽을 의미한다.

(1, 1)과 (N, M)은 항상 뚫려있다.

출력

첫째 줄에 알고스팟 운영진이 (N, M)으로 이동하기 위해 벽을 최소 몇 개 부수어야 하는지 출력한다.

예제 입력 1

3 3
011
111
110

예제 출력 1

3

예제 입력 2

4 2
0001
1000

예제 출력 2

0

예제 입력 3

6 6
001111
010000
001111
110001
011010
100010

예제 출력 3

2

 

소스코드

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;
import java.util.PriorityQueue;
import java.util.StringTokenizer;

public class Main {

	private static BufferedReader bf;
	private static StringTokenizer st;

	private static int N, M, result=Integer.MAX_VALUE;
	private static int[][] graph, dist;
	private static int[] dx= {-1,1,0,0};
	private static int[] dy= {0,0,-1,1};

	static class Point implements Comparable<Point> {
		int r, c, cnt;

		public Point(int r, int c, int cnt) {
			super();
			this.r = r;
			this.c = c;
			this.cnt = cnt;
		}

		@Override
		public String toString() {
			return "Point [r=" + r + ", c=" + c + ", cnt=" + cnt + "]";
		}

		@Override
		public int compareTo(Point o) {
			return Integer.compare(this.cnt, o.cnt);
		}

	}

	public static void main(String[] args) throws IOException {

		bf = new BufferedReader(new InputStreamReader(System.in));
		st = new StringTokenizer(bf.readLine());
		M = Integer.parseInt(st.nextToken());
		N = Integer.parseInt(st.nextToken());
		graph = new int[N][M];
		dist=new int[N][M];
		for(int i=0;i<N;i++) {
			for(int j=0;j<M;j++) dist[i][j]=Integer.MAX_VALUE;
		}

		for (int r = 0; r < N; r++) {
			String s = bf.readLine();
			for (int c = 0; c < M; c++) {
				graph[r][c] = s.charAt(c) - '0';
			}
		}
		if(N==1 && M==1) result=0;	// 시작점과 끝점이 같으면 결과값이 0이 됨
		else result=bfs();	// 시작점과 끝점이 다르면 경로 탐색 시작
		System.out.println(result);
	}

	public static int bfs() {
		for(int i=0;i<N;i++) Arrays.fill(dist[i], Integer.MAX_VALUE);
		PriorityQueue<Point> queue=new PriorityQueue<>();	// 문을 부수지 않는 경우를 먼저 탐색해주기 위해 우선순위 큐 사용
		queue.add(new Point(0,0,0));
		
		boolean [][]visited=new boolean[N][M];
		visited[0][0]=true;
		dist[0][0]=0;	// 시작점은 벽의 개수 0으로 설정
		
		while(!queue.isEmpty()) {
			
			int size=queue.size();
			while(size-->0) {
				Point p=queue.poll();
				
				for(int i=0;i<4;i++) {	// 사방탐색
					int nx=p.r+dx[i];
					int ny=p.c+dy[i];
					
					if(nx==N-1 && ny==M-1) {	// 도착점에 다다르면 최소 벽의 수 저장
						result=Math.min(result, p.cnt);
					}
					
					if(isIn(nx, ny) && !visited[nx][ny]) {
						visited[nx][ny]=true;
						if(graph[nx][ny]==0) {	// 벽이 아닌 경우
							dist[nx][ny]=Math.min(dist[nx][ny], dist[p.r][p.c]);
							queue.add(new Point(nx, ny, dist[nx][ny]));
						}
						else {	// 벽을 만난 경우
							dist[nx][ny]=Math.min(dist[nx][ny], dist[p.r][p.c]+1);
							queue.add(new Point(nx, ny, dist[nx][ny]));
						}
					}
				}
			}
		}
		return result;
	}
	
	public static boolean isIn(int r, int c) {
		return r>=0 && r<N && c>=0 && c<M;
	}
}

0-1 BFS 알고리즘을 이용하는 문제였습니다.

해당 알고리즘의 개념을 몰라서 고생했으나, 기본적인 BFS의 개념을 알고 있다면 0과 1 사이에 우선순위를 설정해주어 해결이 가능합니다.

반응형