반응형
문제
방향그래프가 주어지면 주어진 시작점에서 다른 모든 정점으로의 최단 경로를 구하는 프로그램을 작성하시오. 단, 모든 간선의 가중치는 10 이하의 자연수이다.
입력
첫째 줄에 정점의 개수 V와 간선의 개수 E가 주어진다. (1 ≤ V ≤ 20,000, 1 ≤ E ≤ 300,000) 모든 정점에는 1부터 V까지 번호가 매겨져 있다고 가정한다. 둘째 줄에는 시작 정점의 번호 K(1 ≤ K ≤ V)가 주어진다. 셋째 줄부터 E개의 줄에 걸쳐 각 간선을 나타내는 세 개의 정수 (u, v, w)가 순서대로 주어진다. 이는 u에서 v로 가는 가중치 w인 간선이 존재한다는 뜻이다. u와 v는 서로 다르며 w는 10 이하의 자연수이다. 서로 다른 두 정점 사이에 여러 개의 간선이 존재할 수도 있음에 유의한다.
출력
첫째 줄부터 V개의 줄에 걸쳐, i번째 줄에 i번 정점으로의 최단 경로의 경로값을 출력한다. 시작점 자신은 0으로 출력하고, 경로가 존재하지 않는 경우에는 INF를 출력하면 된다.
예제 입력 1
5 6
1
5 1 1
1 2 2
1 3 3
2 3 4
2 4 5
3 4 6
예제 출력 1
0
2
3
7
INF
소스코드
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Arrays;
import java.util.List;
import java.util.PriorityQueue;
import java.util.StringTokenizer;
public class Main {
private static BufferedReader bf;
private static StringTokenizer st;
private static int V, E, K, u, v, w;
private static ArrayList [] adjList;
private static int[] distance;
static class Node implements Comparable<Node> { // 노드를 가중치 오름차순 정렬 가능하도록 만듦
int val, dist;
public Node(int val, int dist) {
super();
this.val = val;
this.dist = dist;
}
@Override
public String toString() {
return "Node [val=" + val + ", dist=" + dist + "]";
}
@Override
public int compareTo(Node o) {
return Integer.compare(this.dist, o.dist);
}
}
public static void main(String[] args) throws IOException {
bf = new BufferedReader(new InputStreamReader(System.in));
st = new StringTokenizer(bf.readLine());
V = Integer.parseInt(st.nextToken());
E = Integer.parseInt(st.nextToken());
K = Integer.parseInt(bf.readLine());
distance = new int[V + 1];
adjList = new ArrayList[V+1];
for(int i=1;i<=V;i++) {
adjList[i]=new ArrayList<Node>();
}
for (int i = 0; i < E; i++) {
st = new StringTokenizer(bf.readLine());
u = Integer.parseInt(st.nextToken());
v = Integer.parseInt(st.nextToken());
w = Integer.parseInt(st.nextToken());
adjList[u].add(new Node(v,w));
}
Arrays.fill(distance, Integer.MAX_VALUE); // 최단 경로 배열을 최댓값으로 초기화함
distance[K] = 0;
dijkstra(K);
for (int i = 1; i <= V; i++) {
if (distance[i] == Integer.MAX_VALUE)
System.out.println("INF");
else
System.out.println(distance[i]);
}
}
public static void dijkstra(int start) { // 우선순위 큐에 시작점을 넣고, 해당 점에서 거리가 가장 가까운 점으로 탐색
PriorityQueue<Node> pq = new PriorityQueue<>();
pq.add(new Node(start, 0));
while (!pq.isEmpty()) {
Node node = pq.poll();
for(int i=0;i<adjList[node.val].size();i++) {
Node next=(Node) adjList[node.val].get(i);
if(next.dist!=0 && distance[next.val]>distance[node.val]+next.dist) {
distance[next.val]=distance[node.val]+next.dist;
pq.add(new Node(next.val, distance[next.val]));
}
}
}
}
}
대표적인 다익스트라 문제입니다. 그런데 배열을 이용하여 구현할 경우, 메모리 초과가 나는 것을 확인할 수 있었습니다.
따라서 우선순위 큐를 이용하여 메모리를 적게 사용하는 방향으로 구현하였습니다.
반응형
'코딩테스트 > 최단 경로 알고리즘(Dijkstra)' 카테고리의 다른 글
[Java] 백준 1162번 : 도로포장 (0) | 2022.03.20 |
---|---|
[Java] 백준 1238번 : 파티 (0) | 2022.03.18 |
[Java] 백준 4485번 : 녹색 옷 입은 애가 젤다지? (0) | 2022.03.18 |
[최단 경로 알고리즘] 최단 경로 알고리즘(Shortest Path Algorithm) (0) | 2021.11.03 |