반응형
문제
그래프를 DFS로 탐색한 결과와 BFS로 탐색한 결과를 출력하는 프로그램을 작성하시오. 단, 방문할 수 있는 정점이 여러 개인 경우에는 정점 번호가 작은 것을 먼저 방문하고, 더 이상 방문할 수 있는 점이 없는 경우 종료한다. 정점 번호는 1번부터 N번까지이다.
입력
첫째 줄에 정점의 개수 N(1 ≤ N ≤ 1,000), 간선의 개수 M(1 ≤ M ≤ 10,000), 탐색을 시작할 정점의 번호 V가 주어진다. 다음 M개의 줄에는 간선이 연결하는 두 정점의 번호가 주어진다. 어떤 두 정점 사이에 여러 개의 간선이 있을 수 있다. 입력으로 주어지는 간선은 양방향이다.
출력
첫째 줄에 DFS를 수행한 결과를, 그 다음 줄에는 BFS를 수행한 결과를 출력한다. V부터 방문된 점을 순서대로 출력하면 된다.
예제 입력 1
4 5 1
1 2
1 3
1 4
2 4
3 4
예제 출력 1
1 2 4 3
1 2 3 4
예제 입력 2
5 5 3
5 4
5 2
1 2
3 4
3 1
예제 출력 2
3 1 2 5 4
3 1 4 2 5
예제 입력 3
1000 1 1000
999 1000
예제 출력 3
1000 999
1000 999
소스코드
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.LinkedList;
import java.util.Queue;
import java.util.StringTokenizer;
public class Main {
private static int N, M, V;
private static int [][] graph;
private static BufferedReader bf;
private static StringTokenizer st;
public static void main(String[] args) throws IOException {
bf=new BufferedReader(new InputStreamReader(System.in));
st=new StringTokenizer(bf.readLine());
N=Integer.parseInt(st.nextToken());
M=Integer.parseInt(st.nextToken());
V=Integer.parseInt(st.nextToken());
graph=new int[N+1][N+1];
for(int i=0;i<M;i++) {
st=new StringTokenizer(bf.readLine());
int a=Integer.parseInt(st.nextToken());
int b=Integer.parseInt(st.nextToken());
graph[a][b]=1;
graph[b][a]=1;
}
dfs(new boolean[N+1], V);
System.out.println();
bfs(new boolean[N+1], V);
}
public static void dfs(boolean [] visited, int current) {
visited[current]=true;
System.out.print(current+" ");
for(int i=1;i<=N;i++) {
if(!visited[i] && graph[current][i]==1) {
dfs(visited, i);
}
}
}
public static void bfs(boolean [] visited, int start) {
visited[start]=true;
Queue<Integer> queue=new LinkedList<>();
queue.add(start);
while(!queue.isEmpty()) {
int current=queue.poll();
System.out.print(current+" ");
for(int i=1;i<=N;i++) {
if(!visited[i] && graph[current][i]==1) {
visited[i]=true;
queue.add(i);
}
}
}
}
}
반응형
'코딩테스트 > DFS & BFS' 카테고리의 다른 글
[Java] 백준 7576번 : 토마토 (0) | 2022.02.25 |
---|---|
[Java] 백준 10026번 : 적록색약 (0) | 2022.02.23 |
[Java] 백준 2210번 : 숫자판 점프 (0) | 2022.02.15 |
[Java] 백준 1743번 : 음식물 피하기 (0) | 2022.02.15 |
[Python] 백준 1967번 : 트리의 지름 (0) | 2022.01.07 |